We are experiencing slow processes in the EU2 region.

Incident Report for Sesame HR

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 16:24 GMT

Investigating

We are experiencing slow processes in the EU2 region.
Posted Oct 30, 2025 - 07:37 GMT
This incident affected: REGION EU2.