Disruption EU4

Incident Report for Sesame HR

Resolved

Due to some bulk deletion tasks, the database became stuck. The issue has been resolved, and we are working to prevent it from happening again.
Posted Aug 17, 2026 - 05:35 BST

Investigating

We are currently investigating this issue.
Posted Aug 17, 2026 - 05:00 BST
This incident affected: REGION EU4.